Internet Standards Organizations (ISOC, IAB, IESG, IETF, IRSG, IRTF)
(Page 1 of 3)
High-quality, widely-accepted open standards become more important the larger the number of people that use a network. The largest network of all is of course the Internet, which connects millions of people on thousands of individual networks into a globe-spanning internetwork. The Internet has revolutionized not only networking and computing, but communication, business, and even society as a whole. One of the critical factors in the success of the Internet has been its development using open standards.
Of course, nobody sat down one day and said "hey, let's create the Internet!" (No, not even Al Gore. ) It began as a small research network, and was developed over time concurrently with the technology set that implemented it: TCP/IP. At first, a relatively small organization was sufficient to manage the development of Internet standards and oversee its activities, but as the Internet continued to grow, this became inadequate. Eventually a more formalized structure of organizations was required, to manage the Internet development process and other activities to ensure the continued success and growth of the Internet and the TCP/IP technologies that power it.
Today, there are six organizations that are responsible for the development of the Internet's architecture, standards and policies, and related activities. They are closely-related, with certain organizations being responsible for oversight of others, as shown in Figure 7. These organizations perform many tasks, and can be somewhat confusing to understand, since many have similar-sounding names and responsibilities. Therefore, I will concentrate mostly on their role in the development of Internet standards, since that is our primary interest in this discussion.
Figure 7: Internet Standards Organizations
The Internet Society (ISOC) oversees the IAB, which in turn directs the IETF and IRTF. The IETF develops current Internet and TCP/IP standards, and is headed by the IESG, which manages IETF working groups (WGs). The IRTF is the IETF's research counterpart, containing research groups (RGs) led by the IRSG.
Key Internet Standards Organizations
Here is a brief description, rather simplified, of the key Internet standards organizations:
Internet Society (ISOC): A professional society responsible for general, high-level activities related to the management, development and promotion of the Internet. ISOC has thousands of individual and organizational members that engage in activities such as research, education, public policy development and standardization. It is responsible for providing financial and administrative support to the other organizations listed below. From the standpoint of standards development, ISOC's key role is its responsibility for oversight of the IAB.
- Internet Architecture Board (IAB): Formerly the Internet Activities Board, the IAB is charged with overall management of the development of Internet standards. It makes "big picture" policy decisions related to how Internet technologies and structures should work, to ensure that various standardization efforts are coordinated and consistent with overall development of the Internet. It is responsible for publishing Internet standards (RFCs). It advises the ISOC, and oversees the IETF and IRTF; it also acts as an appeals body for complaints about the standardization activities performed by the IETF. The charter of the IAB is described in RFC 2850.
- Internet Engineering Task Force (IETF): The IETF focuses on issues related to the development of current Internet and TCP/IP technologies. It is divided into a number of working groups (WGs), each of which is responsible for developing standards and technologies in a particular area, such routing or security. Each area is managed by an area director (AD), who serves on the IESG. The IETF is overseen directly by the IESG and in turn by the IAB; it is described in RFC 3160.
- Internet Engineering Steering Group (IESG): The IESG is directly responsible for managing the IETF and the Internet standards development process. It consists of each of the area directors of the IETF, who make final decisions about the approval of proposed standards, and works to resolve any issues that may arise in the standardization process. The IESG is technically considered part of the IETF and is also described in RFC 3160.
- Internet Research Task Force (IRTF): Where the IETF is focused primarily on short-term development issues, the IRTF is responsible for longer-term research related to the Internet and TCP/IP technologies. It is a much smaller organization than the IETF, consisting of a set of research groups (RGs), which are analogous to the IETF's working groups. The IRTF is overseen by the IRSG and IAB. It is described in RFC 2014.
- Internet Research Steering Group (IRSG): The IRSG manages the IRTF in a similar way to how the IESG manages the IETF. It consists of the chairs of each of the IRTF research groups and works with the chair of the whole IRTF to make appropriate decisions on research activities. It is also discussed in RFC 2014.
ReplyDeleteInternet Standards and RFCS